Skip to content

Eclipse 3.4 (Ganymede) läuft auch nicht!

Das gibt es doch gar nicht! Nachdem ich mit meiner Eclipse 3.2 Version immer mehr Probleme mit Plugins bekomme, da diese kaum noch für die 3.2 Version verfügbar sind, habe ich mal auf die neueste Eclipse Version 3.4 geschielt. Ein Kollege unter Windows installierte diese einfach und startete das alte 3.2 Projekt ziemlich problemos unter der neuen Version 3.4. Das beflügelte mich zu einem Versuch, trotz meiner enormen Probleme beim Update auf die 3.3 Version, dies auch einmal unter Ubuntu zu probieren. Bisher erfolglos! :-(

Die 3.4 funktioniert bei mir im Prinzip. Bedeutet: Sie lässt sich problemlos installieren, 3.2 Projekte laden auch und ich kann sie editieren. Allerdings funktionieren wichtige Sachen auf einmal gar nicht mehr: Das Deployen nach jBoss geschieht in einem Schneckentempo, man kann sehen, dass dabei einzelne Klassen aus dem Projekt in das /temp Verzeichnis kopiert werden und zwar ca. jede Sekunde eine! Vielleicht liegt dies daran, dass mein temp Verzeichnis auf einer anderen Partition als mein Projekt liegt. Deployen kann man so erst einmal vergessen.

Ursprünglicher Anlass war allerdings, dass ich ein Projekt mit den TPTP Plugins profilen wollte. Auch diese scheinen sich korrekt zu installieren, wenn ich dann aber versuche, den Server zu profilen, bekomme ich nur die lapidare Meldung "[Error: FATAL ERROR: JPIAgent can't load ACCollector]". Ein wenig googlen ergibt nahezu nichts, nichts jedenfalls, was mich weiter bringt.

Wohl gemerkt: Der Kollege hat exakt das selbe Projekt wie ich unter Windows von Eclipse 3.2 nach Eclipse 3.4 portiert. Er kann problemlos deployen und profilen.

Das nervt dann nun aber doch reichlich.. Unter Windows hatte ich nie solche Probleme, die Eclipse Version zu wechseln.. :-(

Trackbacks

Grischa

Grischa am : Eclipse Europa und Ganymede: Updates helfen!

"Eclipse Europa und Ganymede: Updates helfen!" vollständig lesen
Nachdem ich mit der Benutzung von Eclipse 3.4 (Ganymede) wieder solche heftigen Probleme hatte, versuchte ich aus reiner Verzweiflung noch einmal eine frische Installation von Eclipse 3.3 (Europa). Ein Versuch mit meinem JBoss Projekt ergab wieder das sel

Kommentare

Ansicht der Kommentare: Linear | Verschachtelt

YellowLed

YellowLed am :

Hm. Auch welcher Quelle stammt denn Dein Eclipse? Ich habe keinerlei Erfahrungswerte damit, wüsste noch nicht einmal, ob man es kompilieren muss ... hm, Java. Eventuell harmoniert es nicht gut mit der von dir verwendeten JRE?

Grischa

Grischa am :

Danke für die Hinweise!

Aber man muss es nicht compilieren und es harmoniert recht gut mit der 1.5sun Version, die ich benutze.

Habe es jetzt aber (größtenteils) hinbekommen, schreibe noch einen kleinen Artikel dazu, was es war.

Kommentar schreiben

Die angegebene E-Mail-Adresse wird nicht dargestellt, sondern nur für eventuelle Benachrichtigungen verwendet.
Dieses Blog erlaubt Dir, Audio Kommentare über audioboo.fm hinzuzufügen. Erstelle einen neuen Boo und gib hier den Link auf die Seite Deines Boos ein.
record
Wenn Du Deinen Twitter Namen eingibst wird Deine Timeline in Deinem Kommentar verlinkt.
Bewirb einen Deiner letzten Artikel
Dieses Blog erlaubt Dir mit Deinem Kommentar einen Deiner letzten Artikel zu bewerben. Bitte gib Deine Blog URL als Homepage ein, dann wird eine Auswahl erscheinen, in der Du einen Artikel auswählen kannst. (Javascript erforderlich)
(Bedingung: 1 Kommentare geschrieben)
Standard-Text Smilies wie :-) und ;-) werden zu Bildern konvertiert.
tweetbackcheck